Symptom
- Candidate has been initiated from RCM but not visible in Onboarding dashboard
- A BP To Do error is visible for the process trigger of this candidate
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Go to BP To Do error
- Search using the Process Trigger of the candidate
- Error
- View user validation errors for Name (email) for Onboarding process trigger XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
User with the email address XXXXXXXXXXX already exists. Please cancel the onboarding process or coordinate with the recruiting manager to update the email address
- View user validation errors for Name (email) for Onboarding process trigger XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
Cause
- Email is unique in Onboarding and candidate cannot have the same as prior process
- Even fresh candidates who did not existed in the system before when initiated creates a data entry with active external suite status from data inspector.
- Candidate doesn't exist in the EP but has entry in Data Inspector > Table_USERS_SYSINFO > candidate will have a valid value of "e"
Resolution
- Please try to restart from the BP To Do error ensuring that the candidate doesn't exist in the system before
- If the restart won't work. it will be necessary to purge the users to allow initiation from RCM
- Upon successful purge, you may restart from the BP error and the user should be visible in the dashboard already
Keywords
onboarding, obx,email address, exist, Please cancel the onboarding process or coordinate with the recruiting manager to update the email address, initiate from rcm, candidate, not visible dashboard, exist , KBA , LOD-SF-OBX-RCM , Initiate onboarding from RCM , Problem
Product
SAP SuccessFactors HCM Core all versions