SAP Knowledge Base Article - Public

3527147 - User with the email address xxxxxxxx already exists. Please cancel the onboarding process or coordinate with the recruiting manager to update the email address - Onboarding

Symptom

  • Candidate has been initiated from RCM but not visible in Onboarding dashboard
  • A BP To Do error is visible for the process trigger of this candidate

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Go to BP To Do error
  2. Search using the Process Trigger of the candidate
  3. Error
    • View user validation errors for Name (email) for Onboarding process trigger XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
      User with the email address XXXXXXXXXXX  already exists. Please cancel the onboarding process or coordinate with the recruiting manager to update the email address

Cause

  • Email is unique in Onboarding and candidate cannot have the same as prior process
  • Even fresh candidates who did not existed in the system before when initiated creates a data entry with active external suite status from data inspector.
  • Candidate doesn't exist in the EP but has entry in Data Inspector > Table_USERS_SYSINFO > candidate will have a valid value of "e"

Resolution

Keywords

onboarding, obx,email address, exist, Please cancel the onboarding process or coordinate with the recruiting manager to update the email address, initiate from rcm, candidate, not visible dashboard, exist , KBA , LOD-SF-OBX-RCM , Initiate onboarding from RCM , Problem

Product

SAP SuccessFactors HCM Core all versions