Symptom
- After saving the settings for 'Set face-to-face interview locations', it redirects to a blank page.
- The picklist label in 'Set face-to-face interview locations' is displayed as Undefined.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Access Manage Recruiting Settings.
- Navigate to Interview Settings.
- Set face-to-face interview locations.
- Select the picklist ID and set the picklist label;
- Click on Save;
- You are redirected to a blank Admin Center Page and the settings are not saved.
Cause
There is a data issue with the picklists configured for the 'Set face-to-face interview locations' settings.
Resolution
Please follow the below steps to solve the issue:
- Access to Manage Recruiting Settings > Interview Settings > Set face-to-face interview locations;
- From the 'Change Language' dropdown on the right side, select English Debug or any other language that does not have a picklist configured;
- Remove the Picklist ID and the Picklist Label "Undefined", save the change;
- Select the desired language from the 'Change Language' dropdown;
- Configure the Picklist ID and the label, then save the change.
Keywords
Interview Settings, Save Issue, Data Issue, String.equals(Object), oldParentPicklistLabel, Change language, picklist label, undefined, redirect to Admin Center , KBA , LOD-SF-RCM-ADM , Admin Center, RBP, Permissions and Settings , Problem
Product
SAP SuccessFactors Recruiting all versions