SAP Knowledge Base Article - Public

3527285 - 'Set face-to-face interview locations' settings cannot be saved - Recruiting Management

Symptom

  • After saving the settings for 'Set face-to-face interview locations', it redirects to a blank page.
  • The picklist label in 'Set face-to-face interview locations' is displayed as Undefined.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Access Manage Recruiting Settings.
  2. Navigate to Interview Settings.
  3. Set face-to-face interview locations.
  4. Select the picklist ID and set the picklist label;
  5. Click on Save;
  6. You are redirected to a blank Admin Center Page and the settings are not saved.

Cause

There is a data issue with the picklists configured for the 'Set face-to-face interview locations' settings.

Resolution

Please follow the below steps to solve the issue:

  1. Access to Manage Recruiting Settings > Interview Settings > Set face-to-face interview locations;
  2. From the 'Change Language' dropdown on the right side, select English Debug or any other language that does not have a picklist configured;
  3. Remove the Picklist ID and the Picklist Label "Undefined", save the change;
  4. Select the desired language from the 'Change Language' dropdown;
  5. Configure the Picklist ID and the label, then save the change.

Keywords

Interview Settings, Save Issue, Data Issue, String.equals(Object), oldParentPicklistLabel, Change language, picklist label, undefined, redirect to Admin Center , KBA , LOD-SF-RCM-ADM , Admin Center, RBP, Permissions and Settings , Problem

Product

SAP SuccessFactors Recruiting all versions