Symptom
- Proxy Now feature is logging out the user;
- The repeated loop of logging out and prompting for company ID persists without successful proxy.
Environment
SAP SuccessFactors HCM Suite
SAP SuccessFactors HCM Core
Reproducing the Issue
1. Click on the 'Proxy Now' button.
2. Enter a name and click 'OK'.
3. The user is subsequently logged out of the instance.
4. A page appears prompting for the company ID.
5. Enter the company ID and press 'Enter'.
6. Instead of proxying successfully, the page refreshes and returns to the original state.
Cause
- Misconfiguration of Personal Information in ACS Services: There might be incorrect configuration of your personal information in the involved ACS services, leading to their inability to properly handle your SLO (single logout) requests.
- Redirection Settings of ACS Services: The ACS services are set to redirect the SLO requests back to login page (e.g. https://performancemanager15.sapsf.com/login) instead of completing the logout directly.
Resolution
- Check Personal Information Configuration: Ensure that the personal information is correctly configured in all relevant IDP and SP (ACS) systems. Compare your configuration with that of other users, especially those who are not facing the logout issue.
- Check ACS Services configuration: Reach out to these ACS services and confirm that they do not redirect SLO requests back to bizx (e.g. https://performancemanager15.sapsf.com/login) when handling logout requests, because BizX does not process any SLO responses.
- For SAP support, please check the internal memo.
See Also
2271773 - Proxy Now Feature | Suddenly logged out when using Proxy Now feature
Help portal guide for Proxy Access: Setting Up and Managing Proxy Access
Keywords
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