Symptom
- After hit "ok" on Proxy Now feature, the user gets logged out of the instance.
- The repeated loop of logging out and prompting for company ID persists without successful proxy.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
1. Click on the 'Proxy Now' button.
2. Enter a name and click 'OK'.
3. The user is subsequently logged out of the instance.
4. A page appears prompting for the company ID.
5. Enter the company ID and press 'Enter'.
6. Instead of proxying successfully, the user is logged out of the instance or being redirect to another BizX environment (such another preview, development or production environment).
Cause
Cause #1:
- Misconfiguration of Personal Information in Assertion Consumer Service (ACS): There might be incorrect configuration of your personal information in the involved ACS services, leading to their inability to properly handle your Single Log Out (SLO) requests.
Cause #2:
- Redirection Settings of ACS: The ACS are set to redirect the SLO requests back to login page (e.g. https://performancemanager15.sapsf.com/login) instead of completing the logout directly.
Resolution
- All URLs listed in the "Authorized SP Assertion Consumer Service Settings" page in Provisioning will receive a "log out" instruction for the current user when executing a proxy. This is what allows that same user to be able to log back in as the proxied target user. It can be that these URLs aren't properly set or needs to have its cache refreshed.
For Cause #1:
- Check Personal Information Configuration: Ensure that the personal information is correctly configured in all relevant Identity Providers and Service Providers (ACS) systems. Compare your configuration with that of other users, especially those who are not facing the logout issue.
For Cause #2:
- In Provisioning, check "Authorized SP Assertion Consumer Service Settings": validate if in the "Logout Url " column, there is no URL such as https://performancemanager15.sapsf.com/login. If there is such URL, this has to be adjuted.
- Reach out to these ACS and confirm that they do not redirect SLO requests back to bizx (e.g. https://performancemanager15.sapsf.com/login) when handling logout requests, because BizX does not process any SLO responses.
For SAP support, please check the internal memo.
See Also
- Help Portal - Setting Up and Managing Proxy Access
- KBA 2660325 - How to enable and disable Proxy Now
- KBA 2087311 - Proxy Management and Proxy Now - SuccessFactors HCM Suite
Keywords
logged out, proxy kick out, proxy now logout, proxy now issue; suddenly logout, proxy logout, proxy not working, unable to proxy, logout, proxy now issue; company ID, back, return, refresh, page back, page return, page refresh, log in, login page , KBA , LOD-SF-PLT-PRX , Proxy , Problem
SAP Knowledge Base Article - Public