Symptom
You maintain an Approval Process for Sales Quotes, however the Approval Process is not triggered when you submit the Sales Quote.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center
- Go to the Approval Processes work center view
- Maintain an Approval Process for Sales Quotes
- Go to the Sales work center
- Go to the Sales Quotes work center view
- Open Sales Quote 123 (Where 123 refers to the Sales Quote ID)
- Click Actions
- Click Submit
- Go to the Approval facet of Sales Quote 123
Result: No data in the Approval Process section
Expected Result: You see the name of an Approver.
Cause
There is a space before the value of conditions.
Example
You maintain a condition: Group 1 | Sales Organisation ID | Equal to | KTSUB.
You expect the Approval Process to be triggered when the Organisation of Sales Quote is KTSUB, however it is not triggered.
When you check the value of the condition, there is a space so the system doesn't recognise KTSUB on the Approval Process & Sales Quote to be the same.
Notes
- This is only one of the causes. Refer to other KBAs in See Also section
- This applies to Approval Processes for any Business Objects
- A space before the value can be observed only in the edit mode. See the below screenshots.
Conditions in Edit Mode
Conditions in Standard Mode
Resolution
To remove a space before the value.
See Also
Other KBAs regarding the issue.
Keywords
approval process, not working, space, condition, edit , KBA , AP-RC-GEN-BTM , Business Task Management - Configuration , LOD-LE-CQP , Customer Quote Processing , Problem
Product
Attachments
Pasted image.png |