Symptom
When trying to create a new contract from template, a contract template is not displayed on the selection, even though it is active.
Environment
SAP Business ByDesign
Reproducing the Issue
- Navigate to the Sales Orders workcenter.
- Go to the Contract Templates view.
There are active templates on the system.
- Go to the Contracts view.
- Click on New -> Contract.
- Enter an Account.
- Enter a Sales Unit.
- Click on Create From Template button.
- Click on the value box.
One or more templates are not displayed on the options, even though it is active on the system according to the Contract Templates view.
Cause
In the drop-down list on the Contract Template ID field, the system proposes only templates that:
1. Are released
The system does not include templates that are not active.
2. Match the sales organization and distribution channel of the account entered in the Contract
The system also includes templates that do not have a sales organization and distribution channel specified.
3. Contain products that would not cause an error if added to the new contract
The system draws up a product list based on products at item and entitled product levels, and checks these products against the sales organization and distribution channel of the account. If a product does not match, and would therefore produce an error if added to the contract, the system filters out the related template.
4. Contain at least one item
The system filters out templates that do not have any items.
NOTE: In case a template is not proposed on the selection and the reason is unknown, it is possible to manually enter the template ID on the Contract Template ID field and check the error messages. The inconsistencies will be displayed by the system.
Resolution
Check and assure that the relevant contract template match all the criteria above.
See Also
Keywords
contract template, customer contract, active, template selection, not displayed, not showing, not possible, sales order, byd. , KBA , AP-SLO-SO , Sales Order , How To