SAP Knowledge Base Article - Public

3528645 - Technical Error Occuring when Saving the TMP Billing Document

Symptom

When creating billing documents, after saving the TMP file, a runtime error occurs:

Sorry, a technical error has occurred. Please try again later.
{
    "message": "HTTP request failed",
    "headers": [],
    "statusCode": 500,
    "statusText": "",
    "responseText": "DBSQL_DUPLICATE_KEY_ERRORRuntime Error: 'DBSQL_DUPLICATE_KEY_ERROR'. The OData request processing has been abnormally terminated. If you use SAP S/4HANA Cloud, please create an incident. Otherwise, if \"Runtime Error\" is not initial, launch ADT feed \"Runtime Errors\" or transaction ST22 / SM21 (system log analysis) for details and analysis.20241011074402"
}

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open "Create Billing Documents" app.
  2. Select one SD document and click "create billing documents" button.
  3. Save the billing document and the error occurs.

Cause

One of the reasons for such run time error, lies in improper customizing for number range.

Resolution

Modify the configuration in the configuration activity "Define Number Ranges for Billing Documents"(ID:103284).

Keywords

create, billing document, save, customizing, number range, dump, DBSQL_DUPLICATE_KEY_ERROR , KBA , SD-BIL-IV-2CL , Processing Billing Documents (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions