Symptom
When a custom picklist is defined in candidate profile template and the user access the application for the first time in new workbench, then the value of the picklist is not shown but it appears only after the page is refreshed.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to Recruiting and Open any Job Requisition that has Candidates in the New Application Status.
- Open any candidate whose snapshot has not been taken, i.e. the Application is opened by the recruiter for the first time.
- Scroll down until you see the affected field on the Application.
- See that the field shows no selection.
- Now hit the refresh button and see that the Value gets populated.
- The issue can be reproduced on any application, on any requisition whose application snapshot has not been taken.
Cause
The candidate profile API is only retrieving snapshot data. When the user access the application for the first time, it trigger asynchronously API to create the snapshot, so that's why the user doesn't see the data until the page is refreshed.
Resolution
- The engineering team is aware of the issue and a fix is scheduled on 16th May 2025 (b2505 release).
- As this issue only happens for newly defined picklists and workaround is to refresh the page.
Keywords
application, candidate, picklist, custom, field, data, disappears, refresh, API, , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem