Symptom
The issue is observed when using the standard filter in the report, however, the opportunities are visible when directly accessing the Opportunity WorkCentre.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Business Analytics
- Go to Design data sources.
- Open the data source and in the field "Main Employee Responsible", add the user ABC.
- Run the report.
- In the row, add Opportunity and "Main Employee Responsible".
- Observe that only XYZ opportunities are displayed.
- Compare this with the Opportunity WorkCentre where more opportunities are expected to be displayed for example instead of XYZ number of opportunities you see XYZWK
Cause
The issue arises from the fact that the analytics selection differs from the Opportunity WorkCentre view. The standard filters such as "My Team" or "My Reporting Line" are used for data retrieval where opportunities of all employees belonging to the same team are expected to be displayed.
Resolution
- Understand that analytics performs a different selection than the Opportunity WorkCentre view.
- Refer to the documentation for "My Team" at the provided link to understand the selection logic.
- Note that to influence the "My Team" selection, an enhancement spot OrgUnitEmployeeMyTeamQueryModify (ES_ORG_UNIT BADI_ORG_MODIFY_MY_TEAM) is available in PDI Dev Studio to enhance or modify the logic.
- Be aware that "My Team" queries ignore the functions of the organizational units a manager or employee is assigned to. In contrast, for reporting purposes in analytics, the function "Reporting Line Unit" of an organizational unit is checked.
- Understand that different results might be obtained due to this standard logic, which cannot be changed as it would be incompatible for other customers.
See Also
Keywords
Opportunity, Standard Filter, My Team, My Reporting Line, Analytics, Reporting Line Unit, OrgUnitEmployeeMyTeamQueryModify, ES_ORG_UNIT BADI_ORG_MODIFY_MY_TEAM, PDI Dev Studio. , KBA , LOD-CRM-OPP , Opportunity Management , Problem