SAP Knowledge Base Article - Public

3530145 - Address Portlet: No History Data Available and Missing Delete Button - Employee Central

Symptom

  • No history data available and the Delete button is missing
  • The address record appears with the values as strike-through
  • The record cannot be deleted permanently from the UI due to the absence of the delete button.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Go to: Employee Profile
  2. Access the Address portlet and click on History.
  3. Notice the last record has the values as strike-through and there is no delete button.

Cause

The address was likely deleted from the Edit action instead of Delete, which is why this issue occurred. This is not an issue with the system design.

Resolution

Reimport Address information in Full Purge mode.

See Also

2317955 - How to Correct or Remove Job Information Via Import in Full Purge Mode - EC

Keywords

SAP SuccessFactors, Employee Central, Address Information, Delete Button, Missing, Address Portlet, Full Purge Mode, Import, No History Data Available , KBA , LOD-SF-EC-PER-ADR , Home Adress - Config, Rules, RBP, UI , Problem

Product

SAP SuccessFactors Employee Central all versions