SAP Knowledge Base Article - Public

3530345 - Alert not generated when having multiple records on the same event date

Symptom

  • When editing multiple records on the same event date or adding another slice without changing the subject field, no alert is created.
  • System only checks the last record when having multiple records on one event date in Job Information.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

1. Alert rule is configured as follows:

2. Update the Probationary Period End Date field in both records to the same date, for example: Oct 30, 2024; or add a second slice on the same event date without changing the Probationary Period End Date.

3. After the alert job is completed, you find no alert is created. And as per the rule trace, the system only checks the second record on that event date. Since the Probationary Period End Date value is equal to previous value, the alert is not generated.

Cause

This is expected by current system design. As Job Information Portlet is effective-dated, only effective records will trigger alert. In case of multiple records on one event date, the latest record is effective.

Resolution

As the workaround, please directly edit on the record instead of inserting a new record for the same event date.

If you wish for this to be considered as an improvement in a future release, you could submit an enhancement request as per the below KBA: 2090228 - How to Submit Ideas for SAP SuccessFactors Products

Keywords

not triggering, EC alert, notification, job information, business rules, latest record
, KBA , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , Problem

Product

SAP SuccessFactors Employee Central all versions

Attachments

Pasted image.png