SAP Knowledge Base Article - Public

3530733 - Return to Customer Deliveries Query Not Working

Symptom

You are trying to check the Return to Customer Deliveries in the work center view Outbound Logistics Outbound Deliveries, but the system displaying only up to a particular Shipment/Pickup Date of dd.mm.yyyy (dd.mm.yyyy represents the calendar date) which is not the most current date.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to the Outbound Logistics work center. 
  2. Go to the Outbound Deliveries view. 
  3. Show Return to Customer Deliveries.
  4. You can see the system is not displaying the most up to date document.

Cause

Huge number of records in the system leading to the issue.

Resolution

We can see more that 10000 records in backend for the query Return to customer Deliveries. From backend we had checked and found that the retrieve query fetches all records and on User Interface, it show randomly only 10000 records. When we have a situation having more records, we have used the Advanced Filter to get the appropriate data and that is what we recommend in this case.

  1. To overcome this issue,
  2. Please open the Advanced Filter.
  3. Go to Organize Query.
  4. Remove the checkbox execution on selection for Return to Customer Deliveries.

The query will then not automatically execute when you select Return to Customer Deliveries. Afterwards, you can use the Advanced Filter to get the data as per your business requirement reducing the number of search hits by restricting the search criteria. We have checked the same by providing a shipment date range of dd.mm.yyyy to tt.mm.yyyyy, and we are able to get the latest document. 

dd.mm.yyyy represents a date of the calendar.

tt.mm.yyyyy represents today's date (the day you are doing the search).

Keywords

Date filter, Advanced Filter, Outbound Delivery, query, wrong , KBA , AP-ODP-OD , Outbound Delivery , Problem

Product

SAP Business ByDesign 2408