Symptom
System is throwing the error "Complete all the mandatory activities before progressing" when trying to set Opportunity to "Won" status.
Environment
SAP Sales Cloud V2
Reproducing the Issue
- Open Guided Selling.
- Open Opportunity ABC.
- Click "Set Status".
- Set to Won.
- Set a Reason for Status.
- Error appears.
Cause
The error is happening due to the configuration maintained in Opportunities General Settings, which is the "Opportunity Won Status" toggle set to true.
It means that, if there is any mandatory activities which need to be performed by user, the change of status to "Won" will be restricted with message "Complete all the mandatory activities before progressing". All other status change are possible.
Resolution
If you would like to remove this restriction so the user can set an Opportunity to "Won" without finishing all mandatory recommendations, you can follow the steps below:
- Go to User Menu.
- Select Settings.
- Select All Settings.
- Search for Opportunities.
- Navigate to General Settings.
- Go to "Opportunity Won Status" section and disable the button.
- Now the error message shouldn't appear anymore when setting the Opportunity to Won.
Keywords
Guided Selling , Opportunities , Won , Status , Progress , Playbook , KBA , CEC-CRM-GS , Guided Selling/Opportunity for SAP Sales/Service Cloud , Problem