Symptom
Field(s) suddenly disappeared from the metadata via OData API and the issue can be resolved by simply refreshing the metadata.
Environment
SAP SuccessFactors HCM Suite
Cause
This as a known design limitation in corner cases.
Sometimes, like in cases of temporary DB connection failure, the engine cannot build a complete metadata but tries to retrieve as much as possible. This can result in an incomplete metadata being retrieved.
Resolution
- Go to OData Metadata Refresh;
- Click on Refresh;
NOTE FOR SUPPORT: There is an enhancement request for that with the Engineering team. The internal numbers are ECT-244434 &
SFAPI-32436. Please, share new examples there to give visibility to the enhancement.
See Also
OData API Metadata Management chapter - OData API guide
Keywords
SuccessFactors, OData, Integration Center, refresh, missing, field, navigation, metadata, limitation, incomplete , KBA , LOD-SF-INT-ODATA , OData API Framework , Problem