SAP Knowledge Base Article - Public

3531691 - Incorrect Sender Name Displayed In Ticket Interactions For Outbound Emails

Symptom

In the Ticket Interactions of the Service Work Center, the sender name displayed for outbound emails is incorrect. Instead of displaying the name associated with the sender’s email address, the system displays the name of the user who is logged in and sent the E-mail.

Environment

SAP Cloud for Customer core applications

Reproducing the Issue

  1. Navigate to the Service Work Center.
  2. Open the Tickets View.
  3. Select any Ticket.
  4. Navigate to the Interaction Facet.
  5. Compose and send a new email or reply to an existing email.
  6. Observe that the email activity created displays the name of the user who sent the email, instead of the name associated with the sender's email address.

Cause

This is the current system's expected behavior. The system is designed to display the Business User's name from which an Outbound E-mail is sent. This is to keep track of the information of the users who send an email from the system.

This is applicable also on scenarios where there is an automatic outbound E-mail sent on an immediate Ticket save. For example: E-mail sent from a Workflow Rule which is on every save.
However, for an email sent via a scheduled workflow rule, since the workflow rule triggers at a later time after the ticket is saved, the sender name will be displayed as the name maintained for the sender email address. 

Resolution

This is the current standard system behavior.

If a change in the feature/functionality is needed urgently, refer to KBA 3475641 - Functionality Currently not Available.

Keywords

Ticket Interactions, Outbound Email, Sender Name, Incorrect, Business User's Name , KBA , LOD-CRM-SRP-INT , Ticket Interactions , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications all versions