Symptom
When attempting to add Sales Data for an account using the Mass Data Maintenance tool in the system the below error message is displayed:
"No Customer Imported. XYZ Customer Failed." (where XYZ refers to the number of customers)
In the Import Log, the error message "Distribution chain not valid: enter distribution channel" appears for all records in the file.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Mass Data Maintenance Work Center.
- Go to the Mass Data Maintenance View.
- Under File Overview sub-tab, in the dropdown select "File for Processing" option.
- Click on the file ABC (where ABC refers to the file name) under File Overview sub-tab.
- Click on Execute Data Import.
- Click on Immediately.
The error "No Customer Imported. XYZ Customer Failed." is displayed in the top of the screen. - Click on the "Failed" option under the Status Column.
- Click on Display Help.
The error message "Distribution chain not valid: enter distribution channel" is displayed.
Cause
One or more Sales Organization in the import file records do not have a rule maintained in the Relevant Distribution Channels option in the Work Distribution View. This rule is required to define a Sales Data (Sales Organization and Distribution Channel) for an account. If this rule is not maintained for the Sales Organization, the error message will appear when trying to define this Sales Organization in the account, as no Distribution channel was defined to be selected.
Resolution
In this scenario, it is required to first check which Sales Organization maintained in the Mass Data Maintenance import file records do not have a rule in the Relevant Distribution Channels option in the Work Distribution View.
To check follow the below steps:
- Go to Organizational Management Work Center.
- Go to Work Distribution View.
- Select the option Relevant Distribution Channels, under Business Area: Sales and Marketing.
- Click on Edit.
- Click on the header of the column Org Unit Responsible.
- In the Filter field, insert one of the Org Units ID which was trying to be imported in the file.
- Check if any rule is displayed for the Org Unit searched.
- Repeat the steps 1-7 for all the Org Units maintained in the Mass Data Maintenance File.
After verifying the Org Units that do not have a rule maintained, it is required to add a Rule for these Org Units by following the below steps.
- Go to Organizational Management Work Center.
- Go to Work Distribution View.
- Select the option Relevant Distribution Channels, under Business Area: Sales and Marketing.
- Click on Edit.
- Click on Add Rule, under Work Distribution Rules.
- Under the Column Org Unit Responsible, insert DEF (where DEF refers to the Org Unit ID).
- Scroll down, in the sub-tab Distribution Channel, define the Distribution Channel for the Sales Organization.
NOTE: The option "All" will define all Distribution Channels for the Sales Organization, however it is possible to define only the specific Distribution Channel that is maintained in the file to be imported in the tool. - Under the Columns "Validity from" and "Validity to", define the start date of the rule and end date of the rule.
- Click on Save.
After adding the rules for all the Sales Organizations required, the import process in the Mass Data Maintenance tool will be validated and the Sales Data records will be imported with no errors.
See Also
Keywords
Mass Data Maintenance, No Customer Imported, Customer Failed, Distribution chain not valid, enter distribution channel, Relevant Distribution Channels, Organizational Management, Work Distribution, Sales Data, Sales Organization , KBA , SRD-CC-MIG-CNT , Migration: Content , AP-BP-SA , Sales Arrangement , How To