Symptom
Address of Account and Contact is overwritten from P.O. Box and PO. Box Postal Code values.
Environment
- SAP Sales Cloud Version 2
- SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Go to Accounts.
- Open Account ABC.
- Check the Account Address in header.
- Fill in the fields "P.O. Box" and "P.O. Box Postal Code" in Account address.
- Then, double check the Account address.
- You can see that P.O. Box Postal Code and P.O. Box are now in the Address line instead of the previous values.
Cause
The formattedPostalAddressDescription is a calculated field. The algorithm to build the formattedPostalAddressDescription based on the single postal address fields is country specific, and based on the fields filled in the corresponding address.
If for one Address street postal address fields and P.O. Box fields are filled for the calculation of formattedPostalAddressDescription, it uses the P.O. Box fields.
Resolution
This is the current behavior of SAP Sales Cloud Version 2.
Keywords
Address , Line, Account , Contact , P.O. Box Code , Replace , Overwritten , KBA , CEC-CRM-ACC , Account for SAP Sales/Service Cloud , How To