SAP Knowledge Base Article - Public

3532275 - Understanding the difference between measure "Count" and "Counter" in eSAC

Symptom

You have created a story and have added a table which has measures called "Count" and "Counter". Now you are wondering what's the difference between these two measures.

Environment

  • SAP Sales Cloud Version 2
  • SAP Service Cloud Version 2

Reproducing the Issue

  1. Go to All Settings  Analytics  Design Stories.
  2. Click New to create a new story. The query designer loads in the SAP Analytics Cloud interface.
  3. In the right pane, under Available Data, select an analytical model and drag and drop it to add it to the query designer.
  4. Click the table icon to select fields from the data source that you want to include in the model.
  5. See "Count" and "Counter"

Cause

"Count" is provided by SAC and "Counter" is provided by Analytics.

Resolution

It's suggested to use Counter field instead of Count field. We have already mentioned in our Help Documentation: 

Design Stories | SAP Help Portal 

Counter is provided by Analytics and we're responsible for its values. 'Count' is provided by SAC and should not be used.

We're in talks with SAC to remove this field from the stories.

Keywords

Design Stories, Counter, Count, Embedded SAC, SAC Stories, C4C,  , KBA , CEC-CRM-ANA , Analytics for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions