SAP Knowledge Base Article - Public

3532861 - The Owner is not correctly determined in Lead

Symptom

When the user creates a Lead from the Account, the field "Owner" and "Owner (Sales)" is always automatically filled with the current user. However, as per configured in party determination in the Lead, the Owner should be automatically filled with employee responsible from the account team.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Customers > Accounts.
  2. Open an Account.
  3. Click on "+" at the top header.
  4. Create a new Lead.
  5. See that the owner is filled with the current user and not with the employee responsible.

Cause

The issue is occurring because of the sales organization used in the account team, which is why the system skips the "Employee Responsible" assignment. When the user adds a sales organization to the "Employee Responsible - Sales" role in the account team, the system cannot determine a unique account owner because multiple employees can hold the same role with different sales organizations. 

This means that, if Employee A is assigned as "Employee Responsible - Sales" with a specific sales organization, the system won't assign an account owner automatically. This is likely to prevent conflicts that can arise from having multiple employees responsible for the same account with different sales organizations.

Resolution

This is the expected system behavior.
 
To maintain an account owner when sales organizations are involved, Implementation Partner should be consulted to consider custom implementation to achieve this requirement.

Keywords

Owner Sales, Owner - Sales, determines, determining , KBA , LOD-CRM-LM , Lead Management , Problem

Product

SAP Cloud for Customer core applications all versions