Symptom
Changed On field in overview is not showing the latest change time.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Products.
- Open the Registered Products.
- Go to Changes facet.
- Check the Change Date/Time field. There is some field changes log (like Reference Date, Warranty, Serial ID, Registered Product Category etc.)
- Go to Overview facet.
- Changed On field is not showing the latest change time in Changes facet.
Cause
- Registered Product OWL/list is build on Installation Point BO, and Changed On field reflects the changes done in Installation Point BO."
- Changed fields have been maintained in this node (SERVICE_PROCESS_INFO) which belongs to a different BO, PDM_INDIVIDUAL_PRODUCT BO.
- It's applicable not only to all standard fields (like Reference Date, Warranty, Serial ID, Registered Product Category etc.) which belongs to PDM_INDIVIDUAL_PRODUCT BO, but also to KUT fields that are maintain in this BO.
- Changes in those fields won't be reflected in the Overview facet Changed On field.
- This is the current design of the system.
Resolution
- This is the standard behavior of the system.
- If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available (C4C).
Keywords
Registered Product, RP, Reference Date, Warranty, Serial ID, Registered Product Category, Changed On, Changes, Last_Changed_Date, C4C , KBA , LOD-LE-IBA-IPO , Installation Point , Problem
Product
SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public