SAP Knowledge Base Article - Public

3533357 - Preconditions Not Working as Expected in SAP Service Cloud Version 2 Case Flow

Symptom

In SAP Service Cloud Version 2, the following issues are observed when configuring case flows based on service categories:

  • Preconditions for specific case flow steps do not work as expected.
  • Steps remain hidden even when conditions are met.
  • Dynamically changing the condition value does not update the case flow step as expected, even after multiple changes.

 

Environment

  • SAP Service Cloud Version 2 1.0
  • SAP Sales Cloud Version 2 1.0

Reproducing the Issue

  1. Check a case flow configuration with pre-set step conditions.
  2. For the precondition, the administrator used for example, "Category Level 1 ID (categoryLevel1/id)" contains XYZ value.
  3. Create a new case using the relevant case type.
  4. Add a status or service category expected to meet precondition criteria.
  5. Observe that the flow step remains visible, contrary to expected behavior.

Cause

  • Configuration issue
  • For example, the "Category Level 1 ID" is a UUID, and the correct value to use is the displayId.

Resolution

  • Use the "Category Level 1 Display ID (categoryLevel1/displayId)" for preconditions.
  • If preconditions are not met, the case flow steps will be read-only, not hidden, and cannot be processed by the agent.
  • For all referenced attributes (like Account, Processor, Category, etc.), ensure that Id/displayID is used when setting conditions.
  • Verify the configuration and ensure adjustments are correctly applied. Contact support if the issue persists.

See Also

Keywords

SAP Service Cloud Version 2, Case Flow, Preconditions, Service Category, Flow Step, Condition Value, inactive step, read-Only step. , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem

Product

SAP Service Cloud Version 2 all versions