Symptom
A Business Role has been configured with access to sales quotes; however, users assigned to this role do not see the requested work center view. Instead, an error message is displayed upon business role assignment, stating: "Rule 02 - Restrict to Managed Sales Units for XYZ Work Center View in Business Role Determined no Restrictions."
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Application and User Management workcenter
- Go to Business User view
- Search for Business User: ABC
- Select Edit
- Choose Access Rights
- Under Business Role Assignment, select relevant Business Role
- Notice the below error:
Rule 02 - Restrict to Managed Sales Units for XYZ Work Center View in Business Role Determined no Restrictions
View XYZ can't be assigned since no restriction could be determined.
Cause
- The restriction rule will be dependent on an org unit assignment such as a sales organization, for example — in this case, if the org unit to which the user is assigned is NOT a sales organization or does not have a sales organization in its immediate hierarchy, the system will not assign the work center (or work center view).
-
Restriction Rule 02 - Restrict to Managed Sales Units limits access to sales units managed by specific employees, and the Business User is not a manager in the system. Consequently, when the system tries to assign authorization for the work center view to the user, it cannot find any managed units by this user.
Resolution
Business Role with Restriction Rule will assign the view only if the restrictions can be determined for the specific view and rule. Hence, ensure that the Business User is a manager or remove the Restriction.
See Also
2749403 - Work Center Or Work Center View Missing for A Business User
Keywords
Business Role, Business User, Restriction Rule, Rule 02 - Restrict to Managed Sales Units, Work center View Not Assigned , KBA , SRD-CC-IAM , Identity & Access Management , Problem