SAP Knowledge Base Article - Public

3533874 - "No Account Data is Missing" Error in SAP SuccessFactors Platform Check Tool

Symptom

  • Reports of users unable to log into the instance via Single Sign-On (SSO)
  • Errors under the "No account data is missing (AccountDataMissingCheckExecutor)" in the User Account Management application of the Check Tool refers to Accounts are showing as missing. Why this happens ? 
  • I am creating users via API and each newly created user shows up in the check tool under "No account data is missing (AccountDataMissingCheckExecutor)". Why this happens ? 
  • I am creating users via API  and I can see it under Data inspector in the Table_USERS_SYSINFO table however it is not showing up in the Table_USER_ACCOUNT table or under the Manage Login accounts tool. Why this happens ? 

Environment

SAP SuccessFactors HCM suite

Reproducing the Issue

The issue can be identified by checking the User Account Management application:

  1. go to the Check Tool
  2. observe the "No account data is missing (AccountDataMissingCheckExecutor)" error
  3. For product support team, Notice that you will see following entry on the application logs
          --:--:--,--- INFO [ODDataProducer] [--.--.--.--] [2944003] [XXXXX-aaaa-CCCC-CCCC-ACACACACAC] ... upsert entity: [EmpEmployment]
  4. Later notice that you will see the following error on the application logs:
          --:--:--,--- ERROR [UserAccountServiceImpl]  [--.--.--.--] [2944003]  [XXXXX-aaaa-CCCC-CCCC-ACACACACAC]... [catalina-exec-52]User account doesn't exist! user id 121212 , username:121212

Cause

The issue may be caused by:

  • Accounts being created without following the import order set by Employee Central mentioned in KBA 2080146 
  • API process creating these users causing inconsistencies by mapping an existing Person ID to the newly created user

Resolution

Run the self-service provided Check Tool to fix these inconsistencies and ensure to fix root cause to prevent future occurrences as follow:

  • Option #1 First, upsert the User entity using user odata v2 before calling EmpEmployment. Refer to our help guide →  🔗  EmpEmployment Upsert | SAP Help Portal  
  • Option #2  Alternatively, initiate a SCIM API call simultaneously with EmpEmployment upsert, effectively creating a user account in the process. For more information, see →  🔗  Create a User | SAP Help Portal 

See Also

  • KBA 3520080 - Login Failure: Redirects to 'Missing Credentials' and No Login Account  
  • KBA 3478054 - Rehire error: "There was an error in saving the user information." 

Keywords

SAP SuccessFactors, Check Tool, No account data is missing, AccountDataMissingCheckExecutor, SSO, User Account Management, API, inconsistencies, Employee Central, import order, missing accounts. , KBA , LOD-SF-INT , Integrations , LOD-SF-PLT-CHK , SuccessFactors Platform Check Tool , Problem

Product

SAP SuccessFactors Platform all versions