Symptom
When navigating to Opportunity Marketplace and trying to view or edit assignment. There will be a Access Denied prompt. Although it is being prompted you will still be able to edit and update some fields.
Environment
- SAP SuccessFactors Opportunity Marketplace
Reproducing the Issue
- Log in to SuccessFactors
- Navigate to Admin Center > Opportunity Marketplace > View Assignments
- Error prompt (Access Denied will appear already)
- Try to edit (Access Denied will also appear but you will still be able to update/save in the field)
Cause
Lacking permissions on Growth Portfolio (specifically)
Attribute (view edit create)
Attribute Type (view edit create)
Proficiency Level (view edit create)
Tags (view edit create)
Resolution
The permission that is missing in the role assigned to the user must be fulfilled.
Granting permission on Growth Portfolio will resolve the issue (below are the specific permission)
Attribute (view edit create)
Attribute Type (view edit create)
Proficiency Level (view edit create)
Tags (view edit create)
Keywords
Opportunity Marketplace, Opportunity, Marketplace, Permission, Growth Portfolio, Access Denied, Access, Denied, Error , KBA , LOD-SF-OMP-ADM , Admin Tools, Permissions, Settings , How To