SAP Knowledge Base Article - Public

3534024 - Error:" No Supported binding was found for SAML SSO profile while verifying the account using custom SAML user mapping in SAP Analytics Cloud (SAC) version 2.0

Symptom

    Error from the popup windows when click verify account : "No Supported binding was found for SAML SSO profile, Supported SAML SSO browser profile bindings are HTTP-POST and HTTP-Redirect. ". 

    Environment

    • SAP Analytics Cloud 2024.21 and higher

    Reproducing the Issue

    1. Log in to SAP Analytics Cloud (SAC) .
    2. Go to System Administration > Security.
    3. Click Edit.
    4. In the Authentication Method, select SAML Single Sign-On (SSO).
    5. In Step 1, download and save the metadata file provided by SAP Analytics Cloud.
    6. Upload this metadata file to your SAML IdP.
    7. Map SAML IdP user attributes and roles to SAP Analytics Cloud.
    8. Download metadata from your SAML IdP.
    9. In Step 2, select Upload, and choose the metadata file downloaded from the SAML IdP.
    10. In Step 3, select a User Attribute: Custom SAML User Mapping.
    11. In Step 4, enter <Your Unique Identifier> here attribute chosen is email ID.
    12. Click on Verify Account.

    Cause

    Unsupported SingleSignOnService was defined in IDP metadata like <md:SingleSignOnService Binding="urn:oasis:names:tc:SAML:1.1:nameid-format:unspecified"

    Resolution

    This requires the IDP administrator to make the necessary changes in IDP.

    The SingleSignOnService service should be:

    <md:SingleSignOnService Binding="urn:oasis:names:tc:SAML:2.0:bindings:HTTP-POST" Location="SAC hostname..."/>
    <md:SingleSignOnService Binding="urn:oasis:names:tc:SAML:2.0:bindings:HTTP-Redirect" Location="SAC hostname..."/>

    Keywords

    SAML, IDP, SAC Authentication / Login, SAC Administration  , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem

    Product

    SAP Analytics Cloud 1.0