SAP Knowledge Base Article - Public

3534347 - Settings Are Missing In The Admin Console For Particular Users In Sales and Service Cloud V2

Symptom

When accessing the Admin Console, some settings are not shown for the logged on user.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

Sales and Service Cloud Version 2

Reproducing the Issue

  1. Click the User Icon on top right of screen and choose Settings.
  2. The Admin Console will open up. Choose the "All Settings" tab.
  3. Search for desired setting.
  4. No results will appear.

Cause

The visibility of the settings in the Admin Console are purely based on assignment of the services and apps in the business role configuration.

If the right services and apps are not assigned to the user business role, they will not appear in the Admin Console when searching.

Resolution

  1. For the affected user, navigate to the assigned business role and open it. 
  2. First, make sure the required service is assigned. For example, if admin user needs to see "Code List Restrictions" setting, service with service ID "sap.crm.service.codeListRestrictionService" needs to be assigned.
  3. Once this service is assigned, it is also necessary to enable the relevant app in the app list.
  4. After these changes, users assigned to this role will be able to see the setting.

Keywords

Setting, Settings, Admin, Administration, Console, Search, Missing, Find, Role, Visible , KBA , CEC-CRM-ADM , Administration for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions