Symptom
A custom status was created and it is desired to add some reason code to this custom status. However, this is not possible as the custom status can't be seen inside Assignment of Reasons.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Business Configuration > Overview.
- Search for Leads activity.
- Click on the dots > Change Immediately.
- Open Assignment of Reasons.
- Click on Accepted or Rejected line.
- Click on add row.
- See the custom status created is not shown as an option here.
Cause
The custom status has internal status different from 'Accepted' or 'Rejected' in Custom Status. For example, internal status is 'Qualified'.
Only leads with either 'Accepted' or 'Rejected' status can have a reason code maintained. If the Lead is maintained with anything different from that, the custom status will not be available for it.
Resolution
In order to add a Reason Code in 'Assign Reasons', the custom status must be either 'Accepted' or 'Rejected'. Once status is maintained as one of the before mentioned statuses, it will be visible it in the dropdown.
This is the standard system behavior.
Keywords
Assign Reasons, configuration status, statuses configuration , KBA , LOD-CRM-LM , Lead Management , Problem