SAP Knowledge Base Article - Public

3534624 - Cannot save layout as a view in application - SAP S/4HANA Cloud Public Edition

Symptom

  • After changing the layout of the application, cannot save the layout as a view. The "Save as" button is missing.
  • After saving the layout as view, the new view cannot be found.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Access a app like "Manage Purchase Order"
  2. Change some layouts like add a filter or column.
  3. Save the new layout as a view.
  4. There is no "Save as" button. Or the new view cannot be found when accessing the app again.

Cause

Parameter UI5FLEX_ENABLE_VARIANTS specifies if users are allowed to create and adapt views and whether they're allowed to share them. 

In the app "Manage Launchpad Setting", the parameter UI5FLEX_ENABLE_VARIANTS is set to NONE, which means that users are not allowed to create or adapt views. They can still set a view as favorite and change their default view. Optionally, they can also choose whether a view should be applied automatically, meaning a search should immediately be triggered as soon as the view is selected. 

Resolution

 In the app "Manage Launchpad Setting", set the parameter UI5FLEX_ENABLE_VARIANTS to PRIVATE or PUBLIC:

  • PUBLIC (default)

    Users are allowed to create and adapt new views. By selecting the Public checkbox, they can also share them with other users.

  • PRIVATE

    Users are allowed to create and adapt new views, but the Public checkbox is not displayed, preventing users from sharing views.

See Also

Save Your Personal Settings as a View | SAP Help Portal

Keywords

Save as, view, UI5FLEX_ENABLE_VARIANTS, layout, Save as a view , KBA , CA-UI5-FL-RTA , SAP UI5 Runtime Adaptation , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions