SAP Knowledge Base Article - Public

3534851 - Sorting and Advance Searching is not Working In Contract Account Screen.

Symptom

Standard Sort and Standard Advanced Filter Options in Contract Account Screen Does not Work as Expected.

Environment

SAP Cloud for Customer

Reproducing the Issue

1. Open utilities workcentre 
2. Go to contract account
3. Apply sorting to column "Contract Account"
4. Observe that the Sorting is incorrect

Cause

This behavior is as per system design.

Resolution

Ideally natural numbers are stored in a character field (i.e. left aligned), so that e.g. '1000' < '9'.
Hence for a different behavior you can use another suitable field with implementation type alphanum (i.e. right aligned). 

See Also

Relatable Component - BC-ESI-ESF

Keywords

BC-ESI-ESF , Utilities , Contract Account , Sorting . , KBA , LOD-CRM-IND-UTL , Utilities , Problem

Product

SAP Cloud for Customer core applications all versions