SAP Knowledge Base Article - Public

3535079 - Time Account Not Updated After Termination Rule Execution

Symptom

  • A termination rule is created to calculate annual leave based on different scenarios.
  • After terminating an employee, the rule is executed but the time account is not updated.
  • The expected behavior is for the time account to automatically update to reflect the prorated annual leave entitlement upon termination.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. An employee is hired, with an entitlement of 10 days annual leave.
  2. Then terminate the employee.
  3. The remaining annual leave quota should be recalculated to 3 days.
  4. The simulate account during termination shows the correct calculation, but the time account does not reflect the change after termination.

Cause

In Manage data >> Time Management Configuration:

the Earliest Possible Recalculation Date is set to 01/01/1900.

the Schedule Immediate Recalculation is set to Never.

Resolution

  1. Navigate to Manage data >> Time Management Configuration.
  2. Set the Earliest Possible Recalculation Date to a recent date, for example, 01/01/2020.
  3. Set the Schedule Immediate Recalculation to Always.
  4. The time account will now update immediately upon termination.

See Also

Refer to the official handbook for further reference.

Keywords

Time Management Configuration, Earliest Possible Recalculation Date, Schedule Immediate Recalculation. , KBA , LOD-SF-EC-TIM-TEH , Termination End Handling , Problem

Product

SAP SuccessFactors Employee Central all versions