SAP Knowledge Base Article - Public

3535314 - How to rule in/out IP allowlisting issue in SAP Datasphere

Symptom

  • You have installed an SAP Datasphere installation and need to connect some satellite systems. 
  • The connection is failing. 
  • This could be a Data Provisioning (DP) Agent or any other satellite system which is connecting. 
  • In this KBA we will show how you can quickly rule in or rule out an IP Allowlisting issue. 

Environment

SAP Datasphere

Cause

Depending on the type of connection you are making, it will be necessary to Allowlist the IP's of the connecting systems. 
Refer to KBA 3456052 FAQ: About IP Addresses used in SAP Datasphere, for more details on this. 
This KBA shows a very quick way to rule in or rule out IP Allowlisting as the reason for the connection error. 
You can temporarily allow all IP's and if your connection is then successful, then you will know the reason for the connection error is IP related. 
You can then identify the correct IP or IP range for the connection system and add this into the SAP Datasphere tenant. 

Also to note, it is not recommended or advised to allow all IP's for a prolonged basis. This is merely recommended for a brief testing period and then the configurations as below should be removed. 

Resolution

  1. Logon to the SAP Datasphere tenant
  2. Go to System -> Configuration -> IP Allowlist -> Trusted IPs



  3. Click on Add in 0.0.0.0.0/0



  4. Test your connection and if it is successful you can focus on identifying the correct IP or IP range for the connecting system(s). 
  5. Remove the option here to allow all IP's after the testing is completed. 

See Also

Keywords

DS, DPAgent, SAP Cloud Connector, SCC, security, firewall, restrict, limit, SAP DBTech JDBC: Cannot connect to jdbc, Ensure that the IP address of the agent host is allowlisted in SAP HANA system. , KBA , DS-DI-CON , Connections , HAN-DP-SDI , SAP HANA smart data integration (SDI) , Problem

Product

SAP Datasphere 1.0