SAP Knowledge Base Article - Public

3535501 - Objectives are not loaded automatically when creating a Visit

Symptom

Objectives are not loaded automatically when creating a Visit. 

Environment

  • SAP Sales Cloud Version 2
  • SAP Sales Cloud and SAP Service Cloud Version 2 

Reproducing the Issue

  1. Go to Visits.
  2. Create a new Visit.
  3. Click Save and Open
  4. There are no Objectives under Objectives section.
  5. Click refresh.
  6. Now the Objectives are shown. 

Cause

Objective generation is an asynchronous process. When a Visit is created, an objective generation process is triggered via events, which may take a few seconds to complete. During this period, the Visit will not have objectives attached. Sometimes, this process completes in less than a second, in which case the objectives will already be attached to the Visit when it is saved and opened.

Resolution

The Refresh action in Visit will reload the Visit in the UI. If objectives are successfully generated during this reload, they will be attached to the Visit and displayed in the UI.

The "Refresh Objectives" action should only be used if some objectives are not generated correctly or if some objectives are missing.

Keywords

Visits , Objectives , Activities , Reload , Refresh , Appearing  , KBA , CEC-CRM-VST , Visit for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions