Symptom
You are replicating C4C Opportunities from CNS to CRM using Send Event Notification action in Autoflow and missed the following information in the JSON payload triggered out by Autoflow:
- The Display ID (DisplayId) for key information such as primaryContact, owner, salesOrganisation, salesUnit, contacts, salesTeam, and involvedParties is missing. Only the technical ID is sent.
- Only the Primary Sales Team member ("isPrimary": true) is being sent, leaving out the rest of the team.
The autoflow is triggered when an opportunity is created or updated. While creating the autoflow, you have selected the event notifications action in order to send opportunity data to an external system.
Environment
CRM
ECC
SAP Sales Cloud Version 2
Reproducing the Issue
- Go to Settings
- Search for Autoflow
- Create a new Autoflow and fill out the mandatory fields
- Select the respective Communication System
- Subscribe path: e.g. /http/CNS/CRM/opportunity
- Set the Event name: sap.crm.custom.event.Oppt
Cause
This is the system behavior.
Autoflow is not the same as opportunity replication framework.
Resolution
Concerning autoflow event, this is the logic for outbound information sent:
1. Event will only have technical IDs. DisplayID will not be present since this data is not persisted in opportunity. Its enriched information based on master data available during UI display;
2. Sales team in UI includes Owner. This will not be there in the event as part of Sales Team but is available at the header. Other than owner, all other roles will be there in Sales Team.
Keywords
Autoflow;primaryContact;displayID;opportunity;payload , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , CEC-CRM-AFL , Autoflow for SAP Sales/Service Cloud , CEC-CRM-GS , Guided Selling/Opportunity for SAP Sales/Service Cloud , Product Enhancement