Symptom
"Earliest Start" and "Latest End" date are blank in service contracts. Also the CDS view "I_SERVICECONTRACT" displays 0 for both fields.
Environment
SAP S/4HANA Cloud Public Edition
Cause
The issue occurs because CONTERLSTDT (Description: Earliest Start of Contract) and CONTLTSTDT (Description: Latest End of Contract) are missing in the date profile being used.
Resolution
Add date types CONTERLSTDT (Description: Earliest Start of Contract) and CONTLTSTDT (Description: Latest End of Contract) to the corresponding date profile using the configuration activity "Define Date Profile for Service Transactions" (Configuration Activity ID: 104301).
Keywords
Date Type, CONTERLSTDT, Earliest Start, CONTLTSTDT, Latest End, Service contract, Date Profile, 104301, 104300, 104327, I_SERVICECONTRACT, CDS view , KBA , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , Problem