Symptom
It is desired to delete a standard party role in the system. However, the delete button is grayed out even though this party is not being used in the system.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Business Configuration > Overview.
- Party Role Definition activity.
- See, for example, 'Account Team Member'.
- It is desired to delete it, but the delete button is grayed out.
Cause
It is not possible to delete standard party roles in neither Party Role Definition activity, nor for the specific business objects. It is only possible to delete custom party roles. Or just not set the specific party role as active for the specific business objects in Maintain Involved Parties.
For example, on Opportunity activity > Maintain Involved Parties > it has 'Account Team Member' which can be set as active or not. For other business objects such as Sales Quotes, Sales Orders and Leads it doesn't have 'Account Team Member' already.
Additionally, as Account is considered master data, there isn't an 'Accounts' activity in BC to deactivate the desired party roles.
Resolution
This is the expected system behavior.
However, please post this request in Influence Site. This is the channel to approach the product management team directly. Development will evaluate the feasibility of the request and provide an statement on the possibility of enabling it on a future release. The product management team is constantly seeking for ideas for new features.
Keywords
greyed out, parties , KBA , LOD-CRM-ACC , Account , LOD-CRM-OPP , Opportunity Management , Problem