Symptom
Users are not able to edit the subject of e-mail activity.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Activities > E-mails.
- Open an e-mail.
- Click on edit.
- See Subject field/section is not editable.
Cause
The Subject field cannot be changed for e-mail activity as per system design. A significant issue/consideration with changing the subject of an e-mail, is the following:
If the subject is changed, and the new subject significantly/fundamentally changes the meaning of the e-mail, then that could negatively impact any instances of that e-mail, which have already been created, especially any instances of the e-mail that include notes or attachments.
For example, if the subject of an e-mail is "Initial call with customer" and the subject is changed to "Call with customer", then there likely would not be any issue/confusion, regarding any instances of that e-mail which already exist (i.e. had previously been created).
However, if the subject of an e-mail is "Initial call with customer" and the subject is changed to "Request approval for price reduction", that is a fundamental change to the meaning of the e-mail, and that may result in issues/confusion for any instances of that e-mail activity which already exists.
Due to the reasons above, the field is not editable to avoid future inconsistencies for the business scenario.
Resolution
This is the expected system behavior.
However, please post this request in Influence Site. This is the channel to approach the product management team directly. Development will evaluate the feasibility of the request and provide an statement on the possibility of enabling it on a future release. The product management team is constantly seeking for ideas for new features.
Keywords
Email activity, email field, email section, emails , KBA , LOD-CRM-OPP , Opportunity Management , Problem