Symptom
When you update a Sales Cycle and Phase in the Business Configuration, "Sales Cycles and Phases", the Progress field in the existing Opportunities is not updated.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Business Configurations work center
- Go to the Overview work center view
- Search for Sales Cycles and Phases
- Click Maintain Sales Cycles to maintain a new Sales Cycles (e.g. Sequence 10 // Analysis Phase Description = 001 - Identify opportunity // Slow after X days = 10 // Stalled after X days = 20)
- Go to the Sales work center
- Go to the Opportunities work center view
- Search for an Opportunity whose Sales Phase is Identify opportunity
- Check the Progress field
Result: It shows Slow. This opportunity was created 25 days ago and based on the previous Sales Cycle, it shows the correct Progress in the field
Expected Result: You update the Sales Cycle (e.g. Stalled after X days = 20) so you expect to see Stalled for the opportunity.
Cause
In the objects which are not master data (e.g. Opportunities which are called transactional data), the information valid from the Business Configuration at the time of object creation is stored within the object itself, so updating the Sales Cycle will not update the Progress field of existing Opportunities, and this is this is an expected system behavior.
Resolution
This is an expected system behavior.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:
Keywords
opportunity, opportunities, progress, sales phase, sales cycle, update , KBA , LOD-CRM-OPP , Opportunity Management , Problem