SAP Knowledge Base Article - Public

3536020 - Discrepancy in Role Specific Competencies or Skills(Attributes) in Performance Form

Symptom

Not all Job Specific competencies (Attributes) or skills are showing up in the performance form created for specific users.

Environment

  • SAP SuccessFactors Talent Intelligence Hub
  • SAP SuccessFactors Job Description Manager
  • SAP SuccessFactors Performance Management

Reproducing the Issue

  1. Login to the customer instance and proxy as affected user.
  2. Please navigate to “Performance” module.
  3. Please open the affected performance form.
  4. Please navigate to the competency section where few/all of the competencies are missing.

Note:

  • Make sure that the Job Profile shows all the competencies and are mapped to the Role and not the Family. 
  • Make sure that the External Code for the Competencies are "Competency"

Cause

The problem is due to the sync from TIH to Job Profile Builder for the affected attributes/competencies.

The attribute is set as active but the competency is still reflecting as inactive. The sync is not occurring due to the invalid behaviors mapped which would reflect in the Check tool.

Resolution

1. Inactivate the behaviors
2. Re-create them in Talent Intelligence Hub
3. Sync attribute will be successful

Whenever we change the status of these competencies it needs to save all the roles where these competencies are mapped. 

Sync all the roles and families through Manage Job Profile Content Import/Export and saved the affected competencies. 

It takes 2-3 min to reflect the changes of these types of competencies (where there is a discrepancy in status between JPB and TIH).

Keywords

success factors, PM, PMGM, COC, JPB, JDM, Job Description Manager, missing proficiency, proficiencies, missing behaviors , KBA , LOD-SF-PM-FAM, INC9398819, Competencies Behaviors Families and Roles , KBA , LOD-SF-TIH-JPB , Job Profile Builder , Problem

Product

SAP SuccessFactors HCM Core 2411