Symptom
The system generates an error message: "invalid manager ID. Please try again." when attempting to update the username of the contingent record if the supervisor associated with that record is inactive (terminated).
Environment
- SAP SuccessFactors Employee Central: Job Information
- SAP SuccessFactors Employee Profile: Accessibility
Reproducing the Issue
- Go to any sample profile and identify the supervisor.
- Change the supervisor's status to inactive (terminated).
- Attempt to update the username of the user from Profile view of userinfo block.
- The system generates the error message: "invalid manager ID. Please try again."
Cause
It is expected behavior that if user is having inactive manager in User Data File.
Resolution
For updates to design, please raise an enhancement request by following KBA 2090228 on "How to submit an enhancement request" as process.
See Also
2090228 - How to submit enhancement ideas for SAP SuccessFactors Products
Keywords
SAP SuccessFactors Employee Central, inactive supervisor, update username, invalid manager ID, error message, user data file , KBA , LOD-SF-EC-ADM , Admin Tools (EC Core only) , LOD-SF-EC , Employee Central , LOD-SF-EP-ACC , SuccessFactors Employee Profile Accessibility , LOD-SF-EP , People Profile , Product Enhancement