SAP Knowledge Base Article - Public

3536681 - ID Mapping Creation via Postman

Symptom

You have used one of API Tool (e.g. Postman, Insomnia, etc.. ) to consume or try out the API Rest through the available methods to retrieve or push data into CNS and want to know how the ID Mapping creating in C4C behaves while using some specific methods, such as PUT and POST.

Environment

Sales Cloud Version 2

Service Cloud Version 2

Reproducing the Issue

Using a third-party API tool, you can make a POST call to one of the available API services.

For example, to create a Product ID in CNS, you would use the following command: `https://<myxxxxx>.crm.cloud.sap/c4c/api/v1/product-service/products`

(where `<myxxxxx>` represents your CNS system URL).

- Method: POST

- Expected Response: 201 (Created)

After making the POST call, log in to your CNC tenant and search for the Product ID you created.

1. Navigate to Settings.

2. Go to ID Mapping.

3. Search for the Product ID under the Product ID Mapping Schema.

You will not find an ID mapping created for the respective Product ID.

Cause

POST method does not create ID Mapping in CNS.

Resolution

To get the ID Mapping automatically created, we should consider the method PUT and not POST.

Via Integration Mapping, the replication always happens with PUT call to CNS.

See Also

POST; PUT; ID Mapping; postman;insomnia

Keywords

KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Bug Filed

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0