SAP Knowledge Base Article - Public

3536687 - Sales Quote External Pricing Is Failing With the Error “"ICF Error when receiving the response: ICM_HTTP_CONNECTION_BROKEN"

Symptom

While requesting external pricing on Quote you are facing the error message “ICF Error when receiving the response: "ICM_HTTP_CONNECTION_BROKEN".

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Sales Quote work center view.
  3. Open the Sales Quote 1234 (where 1234 means the opportunity ID).
  4. Click "Request Pricing" button.

Error: "ICF Error when receiving the response: ICM_HTTP_CONNECTION_BROKEN"

Cause

The SAP Sales Cloud system (C4C) has a standard timeout of 5 minutes for synchronous calls (external pricing) which cannot be changed.

Resolution

Improve the pricing calculation in your ERP/S4 system by checking your custom pricing routines. 

For standard price calculation, refer to KBA 3043096 - Improve performance in SAPLV61Z and SD_COND_ACCESS.

See Also

3043096 - Improve performance in SAPLV61Z and SD_COND_ACCESS 

Keywords

External pricing; timeout; ICM_HTTP_CONNECTION_BROKEN; C4C, Sales, Pricing, Sales Quotes, Sales Orders, Cloud for Customer, , KBA , LOD-C4C-NET , Network Connectivity and Certificates , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer core applications all versions