Symptom
- An error message "Product group XXX differs from the product group of the PO item YYY" is displayed while creating a Service Entry Sheet (SES) by adopting items from a contract, not the Purchase Order (PO).
- The issue arises in SES when the product group in the adopted Contract item does not match with that of the PO item.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Create a contract with multiple service masters having different service groups.
- Create a PO with a single limit item and provide the contract as a reference object. The PO limit item should only have a Purchase contract without a Purchase contract item.
- Also currently its mandator to have a Product group in PO thus enter one of the product groups used in contract
- Create a SES and enter the PO but don't adopt the item from PO rather by adopting items from the purchase contract using Add> choose from drop down "adopt from Purchase contract".
- An error is displayed if there is a difference in the product group in Contract of the SES & In PO.
Cause
The configuration is not enabled for the change in the product group in SES compared to respective PO
Resolution
- Navigate to the APP "Manage your solution".
- Search for SSCUI 106044 - Enable Change of Product Group.
- Click on the button 'New entries'.
- Checkmark 'Product group change'.
- Save the changes.
See Also
Improvement Request Details - Customer Influence
3331372 - Error creating Service Entry Sheets from timesheet entries - SAP for Me
Keywords
SAP S/4HANA Cloud Public Edition, Service Entry Sheet, SES, Product Group, Error, Contract, Purchase Order, PO, SSCUI 106044, Manage your solution, Product group change, , KBA , MM-PUR-SVC-SES-2CL , Service Entry Sheet for Service Procurement (Public Cloud) , Problem
Product
SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions