Symptom
Premise is not findable via Live Activity Center using Point of Delivery - Installation.
Environment
- SAP Cloud for Customer
- Utilities Integration with SAP Cloud for Customer
Reproducing the Issue
On the C4C system:
- Go to the Utilities work center.
- Go to the Premise work center view.
- Search and open the Premise ID 1234 (where 1234 means a generic Premise ID).
- Go to Connection Details facet - You have Installation / Point Of Delivery = 9876 (where 9876 means a generic ID).
- Go to the Service work center.
- Go to the Live activity page search using installation number = 9876 under Advanced search: No records are available.
- Enterprise search using installation number: There is no Results as well.
On the ISU system:
- Go to the t-code ES62.
- Premise ID 1234.
- Go to EEDM11.
- Search for Installation 9876 under Business Partner.
- Hit Enter.
- You can find the Premise in the list.
Cause
This is the standard behavior of the system.
Resolution
You can evaluate and use pre-BAdI provided in service ISU_C4C_FINDPOD2. you may write a custom logic to search based on installment number and bypass the standard logic.
See Also
Keywords
Live Activity Center; Point of Delivery; Installation Number; C4C; BAdI; ISU_C4C_FINDPOD2; ES62; Premise; Premises; Live; Activity; Center; Point; Delivery; , KBA , LOD-CRM-IND-UTL , Utilities , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , IS-U-CS-C4C , Integration C4C - S/4HANA IS-U , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To