Symptom
There is a field in Add-In set as mandatory, and the option to unmark it is grey-out and not changes are allow.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP Sales Cloud V2
SAP Service Cloud V2
Reproducing the Issue
1. Go to the "Settings" > ''All Settings".
2. Navigate to "Groupware" .
3. Click on "Profiles" > choose the Profile affected.
4. Navigate to the "Add-In settings".
5. Select the entity e.g. Appointment/Phone Call.
6. There is a field, e.g. "Category ID", set as Required Field, and it's not possible to unmark it.
Cause
The field is set as "Required" in the "Extensibility Administration" configuration.
Resolution
1. Go to the "Settings" > ''All Settings".
2. Navigate to "Extensibility Administration" .
3. Select the entity affected, e.g. Appointment Service.
4. Go to the "Field Attributes" tab and look for the field.
5. Unmark the "Required" toggle.
6. Refresh the page.
7. Navigate to the "Groupware" > "Profile" > "Add-In settings" > Open the entity.
It will be possible to unmark the option now.
Keywords
Required, Mandatory, Add-In, Field, Groupware, Extensibility , KBA , CEC-CRM-GW , Groupware for SAP Sales/Service Cloud , How To