SAP Knowledge Base Article - Public

3537570 - Error in Return Processing Due to Failed Tax Calculation

Symptom

The following error occurs when opening Return XYZ (XYZ represents the Return ID):

Tax calculation failed; trigger a calculation again. 

When clicking on the Update Pricing button and selecting Completely in the Pricing tab the following errors are displayed in case Vertex is in scope: 

No result returned by external provider

Vertex Error: An unit based tax rule cannot be applied to a line item with a quantitiy of zero. Please ensure that the quantity is not zero and retry.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Select the Returns view.
  3. Open Return XYZ.
  4. The error "Tax calculation failed; trigger a calculation again" occurs.
  5. Navigate to the Pricing tab.
  6. Click on the Update Pricing button and select Completely.
  7. The errors "No result returned by external provider" and "Vertex Error: An unit based tax rule cannot be applied to a line item with a quantity of zero. Please ensure that the quantity is not zero and retry" occur.

Cause

The error "Tax calculation failed; trigger a calculation again" occurs because the Credited Quantity is 0 ea. Since the item has a 0 quantity no price can be determined and therefore also no tax can be calculated.

The Planned quantity is the quantity that is planned to be returned as per the Customer Return Delivery Notification.
The credited quantity is the quantity that actually was returned as per Customer Return Delivery (Inbound Delivery).


As per the standard process, you should not create an Inbound Delivery until the product and the actual quantity is returned.

If you have an Inbound Delivery Request that in the end turns out that no product is actually returned, you need to cancel the Inbound Delivery Request instead of creating an Inbound Delivery with 0 fulfilled quantity.

If you check for example Return XYZ.
In the Document Flow you can see that the Return was created from Customer Return Delivery Notification ABC (ABC represents the ID of the Customer Return Delivery Notification).
The Item has the Delivery Notification Quantity 1 ea (hence, this is the planned quantity in the Return).
The fulfilled quantity in Inbound Delivery EFG is 0 ea (hence, this is the credited quantity in the Return) (EFG represents the ID fo the Inbound Delivery).
That would mean that the products were not returned.
If no product was returned, you should have cancelled the Customer Return Delivery Notification ABC.

If a product was returned but by mistake you created the inbound Delivery EFG with a 0 ea quantity you need to cancel the Return and Inbound Delivery.  

Resolution

  1. Cancel the Return and the Inbound Delivery.
  2. Create a new Inbound Delivery with the Fulfilled Quantity as 1 ea and then release.
  3. Process the newly created return.
  4. Before cancelling the Return, enter the Credited Quantity 1 ea in the Items tab so that the Return will be consistent and can be cancelled without any issues.

See Also

Refer to KBA 2936830 - How to Cancel a Customer Return

Keywords

Return, Tax calculation failed, KBA: 2744399, Error, No result returned by external provider, Vertex Error, Unit based tax rule, Quantity of zero, Inbound Delivery, Credited Quantity, Sales Orders, Returns, Pricing, Update Pricing, Cancel, Fulfilled Quantity. , KBA , AP-SLO-SO , Sales Order , Problem

Product

SAP Business ByDesign all versions