SAP Knowledge Base Article - Public

3537595 - Unable to "Add an agent" when setting up Cloud Connector in SAP Datasphere

Symptom

  • An SAP Cloud Connector (SCC) connection is created between SAP Datasphere and an On-Premise system.
  • The Location ID is added as per requirements in Set Up Cloud Connector in SAP Datasphere | SAP Help Portal.
  • In the Datasphere UI, you can see an option to "Add an agent" and a "Check Configuration" option. 
  • When selecting these, nothing happens.
  • It is not possible to add an agent here. 

Environment

SAP Datasphere

Reproducing the Issue

  1. Navigate to System -> Administration -> Data Source Configuration.
  2. Add a Cloud Connector Location ID in On-Premise Data Sources.
  3. Attempt to Add an agent (see screenshot below) or use the Check Configuration functionality.

Cause

This screen is an iFrame from SAP Analytics Cloud (SAC) which is embedded in the SAP Datasphere Administration view.
For the Datasphere use case, only the SCC Location ID needs to be maintained.
The SAC agent is not necessary to be configured for SAP Datasphere integrations.
This is a low level UI issue which will be addressed in one of the upcoming Wave releases.

Resolution

  1. For SAP Datasphere -> SCC integrations, only the Location ID needs to be maintained here. 
  2. Follow the configuration steps as per Set Up Cloud Connector in SAP Datasphere | SAP Help Portal.

See Also

No additional references provided.

Keywords

DWC30, On-Premise system, connection, IP, port, enable agent, location creation, Cloud Agent, SAP Analytics Cloud. , KBA , DS-DI-CON , Connections , Problem

Product

SAP Datasphere 1.0