Symptom
During the personal data collection process, certain country codes are not visible in the Phone Information section for selection.
- The issue is observed when a candidate tries to add a phone number.
- The issue is not specific to any candidate and is universally applicable.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Proxy as the candidate or login if still is an external user.
- Navigate to Onboarding Dashboard.
- Search for a candidate.
- View Details of Provide Personal Data.
- Complete Task.
- Under Phone Information section, try to add a phone number.
- Select Phone Type as Business.
- Try to select a country code. The desired country code is not visible in the dropdown.
Cause
Misconfiguration. The field is configured as a picklist.
Resolution
The field, as standard, should be a string, and changing the data type to Picklist can cause this type of data issue.
Guide for reference: Data Model Field Information for Employee Central
See Also
Keywords
SAP SuccessFactors, Onboarding, Obx, Personal, Data, Collection, Country, Code, Phone, Number, Permissions, Employee, Data, Employee, Central, Effective, Dated, Entities. , KBA , LOD-SF-OBX-PDC , Personal Data Collection , Problem