SAP Knowledge Base Article - Public

3537675 - Changes in Output Settings are not Registered on the Change log for Customer Invoices

Symptom

Changes made in the Output Settings of a Manual Invoice Request or Invoice Document are not registered on the Changes tab.

Environment

SAP Business ByDesign

Reproducing the Issue

For Manual Invoice Requests:

  1. Navigate to the Customer Invoicing workcenter.
  2. Click on the Common Task New Manual Invoice.
  3. Click on Save. The Manual Invoice now have an ID, and its changes should be registered on the Changes tab from now onwards.
  4. Click on You Can Also -> Edit Output Settings.
  5. Make any change on the Output Settings of a Business Document.
  6. Click on Save.
  7. Go to the Changes tab.

For Invoice Documents:

  1. Navigate to the Customer Invoicing workcenter.
  2. Go to the Invoice Documents view.
  3. Filter for All Invoice Documents.
  4. Search for the ID XYZ (XYZ represents the ID of an Invoice Document which is Not Released yet).
  5. Click on Edit.
  6. Click on View All.
  7. Click on You Can Also -> Edit Output Settings.
  8. Make any change on the Output Settings of a Business Document.
  9. Click on Save.
  10. Go to the Changes tab.

As a result for both documents, it is possible to see that the changes on the Output settings were not registered on the change log.

Cause

Changes on the Output Settings are not registered on the change log for any document.

If the Output Settings are changed, the final setting can be seen on the Output History of the Invoice Document after it is Released.

 

Resolution

This is the expected system behavior.

Keywords

changes, output settings, manual invoice request, customer invoice document, change log, tab, not registered, not displayed, not showing, byd. , KBA , AP-CI-CI , Customer Invoice , How To

Product

SAP Business ByDesign all versions