Symptom
- An error occurs when attempting to print a completion certificate, both as a user and as an admin: "The requested operation is not available. If you continue to experience problems, please contact your administrator, referencing ticket #."
- The issue is isolated to a specific external user ID that contains a special character (comma).
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Access Learning Administration>
- Go to People> Users and search for the affected user>
- Go to Actions> Launch Proxy>
- Click on View All in Learning History>
- Click on the Printer icon under Actions>
- The browser opens a new tab with the error message.
Cause
The user ID is causing a database access issue when running the completion certificate report due to having a special character (comma) in the user ID. Comma (,) should never be used in a user ID or other entity IDs on Learning, as it can cause issues throughout the application.
Resolution
- Ask the user to register on the external Site again, but this time by NOT using comma (,) in the user ID.
- Either manually record the same completions for the new user account (in this case the old account has to be manually inactivated) or merge the 2 user accounts to automatically transfer the completion data to the new user account (this will automatically deactivate the old user).
- To avoid the same issue happening in the future, consider to NOT allow users to select their own user ID when registering on an external site. That function can be turned off under System Administration > User-Created Account > uncheck 'Allow Users to choose an ID while creating a new account'.
Keywords
learning, lms, print, certificate, completion, user, id, special, character, comma, The requested operation is not available. If you continue to experience problems, please contact your administrator, referencing ticket , KBA , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS-REP , Reporting Data , LOD-SF-LMS , Learning Management System , Problem