Symptom
- When the system sends an email, the sender's name is displayed as "Unknown"
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Login to instance
- Trigger an email to be sent to a user (for example the Welcome Email)
- See that the sender email is sent with name "Unknown"
Cause
- The full name of the email sender is determined by the individual who triggered the email. If the user triggering the email does not have a full name maintained in the system, the sender's name appears as "Unknown".
Resolution
- Ensure that all users who trigger emails have a full name maintained in the system.
- If the welcome email is triggered by an automatic system process (like User Import Job), the email sender would be System System.
- If an end user manually sends a welcome email to a user, the email sender would be SuccessFactors Admin.
See Also
- 2087739 - Single Sender and Single Recipient | How They Work and Setting Them Up in SuccessFactor
- 2788096 - Email notification from SuccessFactors come with other email than my user's
- 3446149 - Default email sender address is different for Product instance and Preview instance in DC33
- Managing Email Notifications | SAP Help Portal
Keywords
Email Notifications, Sender Name, Unknown, System-Generated Email, User Name, Email Trigger, System System, Successfactors Admin, Email, Unknown Sender , KBA , LOD-SF-PLT-NOT , Email Notifications , LOD-SF-PLT , Platform Foundational Capabilities , LOD-SF-PLT-SING , Single Sender and Recipient , Problem
Product
SAP SuccessFactors Platform all versions