Symptom
Instance refresh completed with the following error code:
- FAILED_TO_RESTORE_INTEGRATION_SETTINGS
- RE_SUBMIT_S2_JOBS_FAILED.
Environment
SAP SuccessFactors HCM Core
Reproducing the Issue
- Log onto the affected source system.
- Navigate to the Instance Refresh Center.
- Set up a refresh to the target system.
- Observe the refresh operation failure.
- Download the refresh log.
- Notice the presence of the error codes.
Cause
The issue was caused by conflicting data with user's SFADMIN and IPSADMIN, which caused the restore process to fail during the instance refresh operation.
Resolution
The reason why this occurs is as follows:
- First, it checks whether a user with the ID 'IPSADMIN' already exists.
- If no such user is found, it attempts to create a new user where both the ID and username are set to 'IPSADMIN'.
- However, since for example, the username 'IPSADMIN' is already in use, the creation fails.
To resolve the issue:
- Identify the users causing the conflict in the system.
- Update the username for one of the users or purge one of the users from the system.
- Retry the refresh process.
Once this has been corrected, proceed with re-trying the refresh and it will completed successfully.
See Also
Keywords
Instance Refresh Tool, IRT, FAILED_TO_RESTORE_INTEGRATION_SETTINGS, RE_SUBMIT_S2_JOBS_FAILED, refresh failure, user conflict, IPSADMIN, SFADMIN, update username, purge user, IT, LOD-SF-PLT-IRT, failed , KBA , LOD-SF-PLT-IRT , Instance Refresh Tool , Problem